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INTRODUCTION 
 
Maze Creator PRO is a Computer Aided Design software package to facilitate the creation of random 
mazes with solutions to be printed or exported (EMF, BMP, Clipboard).  Mazes can be customized in 
shape, number of starting and stopping points.  The general shape can be altered as well as adding text and 
graphics.  A mask can be applied to help rapidly develop new designs. You can save your work templates. 
This is a great tool for newsletters, newspapers, brochures, and web site free promotions. Many template 
styles are available such as CICRULAR, HEX, TRIANGLES, OCT-BOX, SQUARE, TILERs, and more.  
The PRO version of Maze Creator has special licensing to allow for publishing mazes and is directed more 
to the free-lancing professional or printed media company (newspaper, magazine, etc).  This license allows 
for the unlimited and unrestricted publishing of your work. 
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Maze Creator Settings  
 
Selecting a Style/Template 
 
One of the first things you need to do is to select a Template for the maze you would like to create.  This is 
done through the Maze Options menu, and then selecting Maze Setup.  The template or style is simply the 
overall motif or feeling of the maze.  For example, you could choose a maze with a square or circular maze 
shape.  Currently there are 7 styles as well as a TILER Templates to choose.  To help give a “feel” of the 
style, a sample of the Template is displayed in the Example box.  You will get the following dialog box: 
 

 
 
You can also get this dialog by clicking on the “SETUP” button on the left-hand side toolbar. 
 
Select the Template Style with which you would like to work.  As you click on the radio buttons to the left 
in the Template Selection area, the Template Example on the right will update to show a sample of the 
template.  Once you have selected your template style, click on the Dimensions tab to select the size of the 
template grid. 
 
TILED:  Maze Creator now supports TILERs.  These are graphic images rather than simply lines used as 
part of the other styles.  Please note that some features will work differently or simply not supported with 
this graphical tile system.  For example, the show erased cells does not function with TILERs.  Tilers will 
offer theme based mazes with the possibility of highly rendered graphics. 
 
If you enable Wrap, horizontally will allow the maze to flow from the left edge of the maze to the right 
edge as if these to were joined.  Likewise, vertically wrapping allows the maze to flow off the top to the 
bottom.  Both of these can be selected at the same time.
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Setting the Dimensions 
 
Depending on the Style you selected you will see a dialog box that looks like the following: 

 
 
 
The Dimensions box is active due to the selection of a maze template that can be represented by a width 
and length.  They would be all but the CIRULAR maze.  You can represent the rectangular maze templates 
in the number of CELLs wide and the number of CELLs long.  The basic BOX has one maze unit per 
CELL.  Sorry for the confusion, but with the introduction of newer styles, the CELL became multiple units.  
For example, the HEX template has 4 maze units per CELL, two wide and two long.  We will redefine 
CELL after the Dimensions of the maze are set, later the smallest unit of the maze will be referred to as a 
CELL. 
  
• Cells Wide:  Enter the number of cells wide you want your template to be.  You may be surprised 

with certain Styles, since the actual width may be a multiple of the cells requested.  Some styles have 2 
or 4 units across per “CELL”.  If this is undesirable, divide the Cells Width number in half, etc. 

• Cells Long:  Enter the number of cells long you want your template.  You may be surprised with 
certain Styles, since the actual length may be a multiple of the cells requested.  Some styles may be 2 
or 4 units long per “CELL”.  If this is undesirable, divide the Cells Long number in half, etc. 
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Setting the Circular Dimensions 
 
If you selected the Circular maze style, you will see the following dialog box: 
 

 
 
 
There are only two parameters to configure for a Circular template.  These define the size of the hole in 
the middle of the maze and the number of inner ring cells the maze will contain.  The “% Inner Radius 
Size” defines the size of the hole.  It can range from 0.1% up to 99.9%.  Typical values will range from 4 % 
to 60%, but experiment with this number in combination with the “Inner Radius Cells”.  
 
The Inner Radius Cells is the count of cells on the inner ring of the maze.  For small percent radius, a 
small number of Inner Radius Cells should be selected.  Maze Creator uses this number and the % Inner 
Radius Size to render your maze template.  The goal in the rendering is to keep a somewhat square shape 
for the maze cells.  If you select OK and you see nothing but a white background as your template, you 
need to re-adjust these values.  Start by making the Inner Radius Cells amount smaller until you achieve 
your desired result. 
 
Please note, while maintaining a general square cell size, the number or cells on any particular radius will 
increase as you move closer to the outside edge.  Also be aware that the MASK feature doesn’t work with 
Circular maze styles. 
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Selecting Page Parameters 
 
The page layout can be configured through the “PAGE” table of the configuration box.  You can directly 
open the PAGE table by selecting “Page Setup” from the “File” menu.  It looks like this: 

 
 
 
These parameters can be reset after creating a maze.  
• Page Width:  The width you want the maze to be in inches.  Can be smaller than the actual paper in 

the printer. 
• Page Height:  The height in inches of the maze you wish to create. This value can also be smaller than 

the paper in the printer.  
 
These parameters only affect printing of a maze: 
• Page Margin Left: Bring the maze in this many inches from the left side. 
• Page Margin Top: How far down  the page the maze should be printed. 
 
A support feature has also been added to Maze Creator for printing problems: 
• Enable Printer Debug Information: This feature should not normally be enable but will copy 

important information about your printer device upon printed to the clip-board.  This might be required 
when working with Technical Support incase a printing problem is encountered. 
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Advanced Configuration 
 
This tab is for setting the PEN WIDTH and other miscellaneous parameter. 
 

 
 
Printing Pen Width has been added due to printing and publishing mazes in newspapers, magazines, etc., 
you may be required to use a “heavier” line.  Some printing facilities need a wider line to assure it will be 
reproduced accurately at press time.  The default setting is the “Thinnest”.  The thinnest pen width is one 
physical pixel on your printing device (maybe 1/600 of an inch).  Check with your publishing company for 
their requested line width.  There is a pre-defined 1/100 of an inch.  Also, you can select other and select a 
value for X to make the width X/1000 of an inch. 
 
Select “Make Erased Cells Visible in Layout” if you need help seeing in complex templates what cells 
have been erased.  Maze Creator will highlight those cells in mustard like color to show it is erased. 
 
The “Show Updated Information Window” option;  This feature is currently obsolete and will likely be 
removed from Maze Creator in the future.  It is best to leave the “unchecked”.  With this box check you 
will receive information banners & special offers at the bottom of your screen.  These are not always 
revenue generators for Maze Creator but simple a way for Maze Creator to help other small Software, 
product or service business get free exposure.  You can remove the check from this box to free up the space 
at the bottom of the widow.  (NOTE: The information is not updated and you will see very old offers). 
 
Okay, if you want to see what Maze Creator is doing when it generates a maze, select the “Animate Maze 
Creation & Solving” check box.  Be sure you have the extra time since this option could slow the process 
down depending upon the size of your template. 
 
Random Number Seed:  In most cases you will not need to change this value.  If you ever want to recreate 
a maze you had done before, this value will need to be changed to the “SEED” value of the original maze.  
You will need to record this value if you are ever interested in doing this.  You will need to make sure that 
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in re-creating that maze you make the same selections as before (same blackened, whitened, starting 
locations, etc). 
 
 
COLOR Configuration 
 
To change the default maze template colors for the different portions of the maze, click on the colored box 
to the right of the name. Restore the default color by clicking on the “Restore Defaults” button at the 
bottom of the dialog.  Please note, these settings do not affect the colors used by a Tiler. 

 

 
 
 
The following items can be altered: 
• Maze Pen Color: The lines used to draw the maze itself 
• Blackened: Color used to “BLACK” an area of the maze 
• Erased: Color for display purposes only to help illustrate where the maze has erased sections by the 

“ERASE” tool 
• Solution: Fill color used to show the solution to the maze 
• Visible START/STOP: color to print in the start/stop locations 
• Hidden START/STOP: color to display while laying out the maze, color not printed in final output  
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Once you select a color, a color selector box will open for you to choose your preference. 
 

 
 
If you would like, you can customize the color if the quick select swatches don’t meet your needs.
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GROWTH Configuration 
 
This tab is for setting the maze GROWTH behavior.  This is one of the most powerful features of the 
program.  The GROWTH control gives you, the designer, a chance to influence what the solution of the 
maze will be like.  Look at the GROWTH screen below.  Notice the 8 numbers in a circle.  This is what 
you will change to alter the growth behavior of the maze.  

 

 
 
Now, what do all of these settings mean?  Well, read on.  You will find there are only two major behaviors 
to Maze Creator’s growth control; Relative and Absolute.  The PRO version has both of these settings 
available; the other versions only have ABSOLUTE control.  We will cover these features in a later section. 
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ABSOLUTE GROWTH Configuration 
 
With the “Movement relative to current direction” unchecked as shown below, you are specifying the 
ABSOLUTE direction for the movement of the GROWTH engine. 

 
 
Above also represents the default behavior of the growth engine. This is the default behavior of the growth 
algorithm, much like earlier versions of Maze Creator.  When in doubt, reset the values back to these 
settings.  This implies that there is equal chance to move in any one of the compos directions printed in red.  
These angles are the same as on this printed page, 0 degrees will grown up the page, 180 down, 270 to the 
left and 90 to the right.  This growth algorithm is very sensitive to the SEED location of the maze.  Play 
with these parameters, ultimately, the probability is set as the value at the angle over the sum of all the 
values.  (Please note that these should be integer values only, no decimal point is allowed)  Also, 0 (the 
number zero) can be placed in any boxes to deny growth in that direction.  Try entering 0 in all but one 
direction and keep clearing and re-seeding the maze at different locations while viewing the solution.  This 
will give you a good feel for how it works.  Then set multiple values such as setting 0 to a value of 19 and 
90 to a value of 1, this means 95% of the time it will go up the page and 5% to the right of the page.  When 
the growth algorithm senses that it cannot move in a direction it sets that percent as ZERO.  If there is no 
probability to move in any direction, a random connection will be made to the existing paths, and the 
process will start again. 
 
For a circular maze, UP is towards the outer edge of the maze, DOWN is towards the center hole, LEFT is 
a counter clockwise path, and right is a clockwise path.
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RELATIVE GROWTH Configuration 
 
With the “Movement relative to current direction” checked as shown below, you are specifying the 
RELATIVE direction for the movement of the GROWTH engine. 

 
 
Relative growth is very powerful, it allows you to force a LONG or SHORT path, as well as STRAIGHT or 
TWISTED paths.  The settings above have special meanings as printed in red.  The top value means the 
probability to move straight or forward making the path straight.  The angles on either side represent the 
amount of turning the path can take to the left or right.  The bottom number STOP is used to force the 
growth algorithm to stop what it was doing and pick a new starting point by connecting to the existing path 
and continuing.  Use this in proportion to the other values to limit the length of the paths that are grown by 
the engine. 
 
This STOP behavior also occurs if the algorithm determines there isn’t a valid path to continue the growth 
straight, to the left, or right as allowed buy the probability values entered in this configuration box.  As a 
direction is blocked by something, the probability of moving in that direction is set to zero.  Once all paths 
are blocked and there is zero percent chance of moving, the path with STOP. 
 
This algorithm is much less sensitive to the starting SEED location.  Setting the right values here will give 
your maze the feel of a repeating pattern.  Experiment with these setting, watch what happens to the 
template and the solution each time you seed the maze. 
 
For circular mazes straight is; radial in or out, clockwise or counter clockwise.  
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Mouse Gestures & Keyboard Shortcuts 
 
Maze Creator has built in productivity.  Along with the standard keyboard shortcuts that are expected, 
mouse gestures add another level of productivity and speed.   
 
Keyboard Shortcuts 
 
Refer to APPENDIX A for a list of keyboard shortcuts.  You can also print the separate PDF reference 
sheet included with your installation.  Combinations with backets ‘[ ]’ refer to the name of the key within 
the brackets.  For example ALT+ [ESC] for the Maze Tool Setup would be the ALT key and the ESC key 
at the same time. 

 
Mouse Gestures 
 
You can command Maze Creator through the motion of your mouse.  This will take a little practice but, 
once you have mastered it, you will not need to hunt for key strokes or selected a menu item.  Refer to 
Appendix B for the mouse gesture command reference.  A separate PDF is include for you to print. 
 
Mouse Gesture commands look like this: 

 
This is the “S” command, it is used to toggle “Show Solution”.  
The red, large circles, move to smaller blue circles.  This is the 
proper stroke sequence for this command.  This is how all 
commands will be illustrated.  So in this case, the stroke will 
start in the upper right and end at the lower left of the “S”.  
There are two ways to tell Maze Creator that a mouse gesture is 
being drawn. 
 
The easiest is to hold down the CRTL key and depress the 
LEFT MOUSE BUTTON at the start of your gesture.  Hold the 
CTRL key and LEFT MOUSE BUTTON until you complete 
the stroke.  A positive or negative tone will be heard depending 
upon whether the command was recognized.  Also, the 
command recognized will be displayed briefly in the upper 

right of the screen or a small dialog with some debugging information if not recognized. 
 
Another method frees up one hand.  You can press the space bar to signal to Maze Creator that a gesture 
will follow on the next LEFT MOUSE BUTTON click.  A tone will be played once the space bar is pressed 
to give feedback that a gesture should be drawn. 
 
Mouse gestures use artificial intelligence to compare what you draw to what is in the command library.  
This means you only need to be close to the command, not exact.   Here is a mouse sequence example for 
this command: 
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Working with Maze Creator Layers 
 
Another new arrival to Maze Creator is the concept of layers.  Older users of the product will remember 
simply working with Templates.  There are now 2 graphic layers and a text layer that have been added.  
This will allow more creativity and productivity within Maze Creator.  I the past, users exported the maze 
template into another application to add graphics or text.  This is now history. 
 
The layers have a defined paint order.  The paint order relates to the sequence by which the 
layers/image/text will be rendered upon the output device.  Layers laid down first will be covered by layers 
laid over it later. 
 
Layer Toolbar 
 
The layer selection toolbar will allow you to select or view what is the current active layer.  Here is what 
the toolbar looks like: 

 
The buttons from left to right are as follows. 
Background Layer: First graphics layer in the paint order.  Placing items on this layer will be “BEHIND” 

the template.  The maze will flow over these images.  When placing images on this layer, you 
should use the “ERASE” tool to clear that section of the template.  The other recommendation 
would be to place faint watermarks or images that will not corrupt the lines of the template layer.  
Please see the section “Working with Graphic Layers” for more details. 

Template Layer: Here is where the maze is created.  Form the outline and detail for the template cells, set 
start/stop locations and seed the maze on this layer.  This is second in the paint order, so it will 
overwrite the background layer, letting the background show through in the center of the cells and 
in erased areas of the template.  Please see the section “Working with the Template Layer” for 
more details. 

Foreground Layer: The second graphic layer and is third in the paint order.  Images placed on this layer 
will cover both the template and background layers.  Although you may not need this layer, it is 
here as a convenience.  You could use the background layer and alter the Front-to-Back settings of 
all the images to get the same affect.  This layer should speed up some of your graphics 
placements.  Since this layer will be “IN FRONT” of the template layer, you could end up with a 
hidden portion of the template.  Be sure to erase fully under graphics that may cover template 
cells.  Please see the section “Working with Graphic Layers” for more details. 

Text Layer: If you want to add instruction or notes upon the template, now you can do it with the text 
layer.  This is the forth and final layer in the paint order so it will overwrite all other layers.  You 
will be able to select the location, size, font, color and style of the text to place.  Please see the 
section “Working with the Text Layer” for more details. 

 
Selecting/Viewing Layers 
 
To work on a layer, you need to set it as active.  Do this through the menus Maze Options -> Active Layer 
-> layer, or through the hot keys listed below.  You can hide layers to help reduce clutter while laying out 
your project, which can be done through the view menu View -> layer, or the shortcut listed below.  Please 
note the Solution layer is only visible after seeding a maze and is not available as a work layer. 

LAYER SET ACTIVE TOGGLE VISIBLE 
Back Ground CTRL+1 CTRL+SHIFT+1 
Maze Layer CTRL+2 CTRL+SHIFT+2 
Fore Ground CTRL+3 CTRL+SHIFT+3 
Text CTRL+4 CTRL+SHIFT+4 
Solution NA CTRL+SHIFT+5 
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Working on the Template Layer 
 
Please note that the Template layer is the default layer when you start working with Maze Creator.  Please 
see a later section on changing the active layer. 
 
Loading & Saving a Maze Template & Gallery 
 
You can load and save your creations through the File menu.  Although you can save a “generated” maze 
or solution, the power of Maze Creator is the ability to load/save maze templates.  Templates can be of a 
company logo, illustration, or anything else you desire.  The template is the grid on which the maze will be 
generated.  You can then quickly generate a random maze (and solution if desired).  This function only 
saves the template, it will not include any of the text or graphics added to the other layers.  (This feature 
will be added later)   
 
The Template gallery is another feature to get your started quickly.  Make sure you have an active internet 
connection, select the File menu, then select Show Template Gallery.  Review the list of thumb nails and 
descriptions and simply click on the template with which you would like to work. 
 
 
Editing/Customizing a Maze 
 
Once you have configured the maze, Maze Creator will display a template of the maze it will create.  You 
can use the Edit tool bar to make changes to this template shape or looks.  The Edit Tool Bar from left to 
right (See Figure 1): Reset, Blacken, Erase, Add START, Add STOP, Seed Maze, and Solve maze.  

 

 
 
To use a tool, first left click on a tool.  Move to the location on the template where you would like the 
chosen to take place.  Left click on the cell to apply the tools effect.  For Reset, Blacken, and Erase you can 
hold the left button down and move the mouse to draw or cover a large area.  Each cell the mouse passes 
over will have that tool’s effect applied.  Please remember that here, CELL means the smallest unit of the 
maze template.  That is, one single enclosed space. 
 
The controls are as follows: 
• Setup:  This is a shortcut to the “Maze Setup” options, usually your first step in creating a maze. 
• Reset:  Use this tool to remove any “Blackened”, “Erased”, “START”, or “STOP” from the template.  

This will help clean up your creation. 
• Blacken:  This tool can be used to blacken cells of the maze.  This will allow you to draw pictures or 

write block letter text on the maze template.  These cells will remain BLACK (and unused) after 
creation of the maze.  The right mouse button will “Reset” the cell. 

• Erase:  This tool can be used to create open white areas in the maze.  This may be useful for you to 
insert text or a picture within your maze.  You can create “NON-RECTANGULAR” Mazes by 
“erasing” the outer boarder.  The right mouse button will “Reset” the cell. 

• START:  By default, Maze Creator will add a START in the upper left of the template if you don’t tell 
it explicitly where there should be a start.  Use the right mouse button to place a starting cell that will 
be filled green.  Use the left mouse button to place a hidden start location.  The hidden location will be 
a dimmer green and cause the cell to have no walls when printed or exported.  If a hidden start is place 

Figure 1 – Maze Layer Edit Tool Bar 
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on an edge of the maze template, it will appear as a hole in the printed maze.  Also note that you can 
have more than one starting point.  If you don’t want a starting location defined, then simply add a start 
using this tool and “Reset”.  Otherwise, when you generate the maze, Maze Creator will automatically 
add a starting location. 

• STOP:  By default, Maze Creator will add a STOP in the bottom right of the template if you don’t tell 
it explicitly where there should be a stop.  Use the right mouse button to place a stop cell that will be 
filled red.  Use the left mouse button to place a hidden stop location.  The hidden location will be a 
dimmer red and cause the cell to have no walls when printed or exported.  If a hidden start is place on 
an edge of the maze template, it will appear as a hole in the printed maze.  Also note that you can have 
more than one stop.  If you don’t want a stop location defined, then simply add a stop using this tool 
and “Reset”. Otherwise, when you generate the maze, Maze Creator will automatically add a stop 
location. 

• My Solution: This feature is experimental for the PRO version of Maze Creator.  Select this tool, click 
on the template and drag your mouse for the solution you wish.  You will need to experiment with this 
tool.  Clicking adjacent to the last path should connect to that main path.  This tool can cause sections 
of the maze to become unreachable.  This is desirable to create start/stop locations that don’t have a 
solution. 

• Seed:  If you use the Maze Options -> Make Maze menu selection, Maze Creator will randomly 
select a starting cell and start growing a maze before your eyes.  When you start to Blacken and/or 
Whiten sections of the maze and use the Make Maze option, you may notice nothing happening.  This 
is due to the randomly selected cell being one that has been disabled by your selection.  Use of this 
Grow Maze tool gives you more control on how to grow a maze.  Select this tool and click on the 
location you would like to start growing the maze.  This would be required, for example, if you wanted 
to fill in the letter “O” in a maze.  The inside of the letter will not be filled (or will be the only section 
filled) without the use of this tool. 

• Solve:  (Feature is obsolete, the solution is always created, hasn’t been removed from the Maze 
Options menu as of this release) Creating the solution for a maze is very simple.  After printing out 
your creation, select Maze Options -> Solve Maze.  This will not take very long and will gray out 
portions of the maze that do not make up the solution.  The process of solving the maze will be 
displayed as well. 
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Apply a Mask 
 
Use this feature to import a BMP file to MASK the current template.  You would do this to rapidly develop 
the outline of a maze as in the example below to generate a horse shaped maze.  This took only 5 minutes 
to create!  Your other option would be to spend hours drawing in the horse with the tools listed above.  It is 
found under Maze Options as Apply BMP Mask.  Note, this is not available for Circular maze styles.  
Masks can be made from your favorite images by forcing them to a sellout format and then flood filling 
sections you want to be the maze as “gray”.  Near black colors will blacken that part of the template.  Near 
white colors will be erased from the template.  All other colors, such as gray will be the active template 
where the maze will be generated.  
 
For example: 

 
will become when applied as a template: 
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Mask Gallery 
 
Much like the On-Line Template gallery, there is an On-Line MASK gallery.  This is found under the 
Maze Options menu as Show Mask Gallery.  This gives good examples of Masks, what they look like 
and how they can be used.  Make sure you have a live internet connection before requesting the gallery.  
Review the thumb nails and select.  It is that easy. 
 
Seeding a Maze 
 
When you are satisfied with your customizations and edits to the maze template, you need to Seed the 
maze.  You have two options by which you can Seed a maze.  The simplest method would be to select 
Maze Options -> Make Maze option.  This is a quick method if you have no edits to the maze.  Otherwise, 
you should use the “Seed” tool described in the Editing/Customizing section above.  Once seeded, you will 
have your maze with exactly one solution from each start to stop location.  You then can print out your 
creation! 
 
Solving a Maze 
 
(OBSOLETE, no need to do this, solution is always created once a maze is seeded) Creating the solution 
for a maze is very simple.  After printing out your creation, select Maze Options -> Solve Maze.  This will 
not take very long and will gray out portions of the maze that do not make up the solution.  The process of 
solving the maze will be displayed as well. 

 
Clearing a Maze 
 
After generating a maze, selecting the Maze Options -> Clear Maze function will remove the random path 
on the maze template.  This will allow you to keep your same drawing so you can create multiple random 
mazes. 
 



 

Maze Creator PRO User Manual                                                                                                Page  21 of 33

Working with Graphic Layers 
 
There are two graphics layers.  Both operate the same exact way as the other; they just happen to be 
independent from one another.  Use the background layer for watermarks to light graphics you want the 
maze to run over and through.  Use the foreground layer for sharp graphics you want to stand out and not to 
be covered such as entrance and exit marks, etc. 
 

After selecting a graphics layer, the toolbar on the left will appear.  Working with graphic 
objects is pretty straight forward. 
 
Adding and object:  Left clicking and dragging will display a rectangle.  Once you have the 
size of the object you wish to add, let go of the left mouse button.  This will open a file dialog 
box so you can select a graphics object to insert into the active graphic layer.  Find the graphic 
you wish to add and click “OPEN” to finish the action.  You can select “CANCEL” if you do 
not wish to add an object. 
 
Moving an object: Move the cursor over the object you wish to move, left click and drag the 
object to its new location.  Once in place, release the left mouse button to finish the move. 
 
Resize an object: Float the cursor over one of the eight control handles for the object to be 
resized.  The cursor will change to an arrow indicating the directions it will resize the object.  

Left click and drag the control handle to its new location to resize.  Release the left mouse button when you 
have achieved the desired new size to complete the action. 
 
Select an object: The currently selected object will have a solid outline where other objects on that layer 
will have a dotted outline.  To change the selected object, float the cursor over the new object and left click.  
The outline of the object will become solid to signify the select object. 
 
Unselect an object: If you desire, you can unselect the current object.  This isn’t overly useful for 
graphic objects but may be desired for a fast preview.  This can be accomplished by left clicking 
somewhere on the layer and releasing where no object exists.  This can also be done by changing to another 
layer and then back again. 
 
Delete an object: You can delete the currently select object at any time by clicking the “DELETE” 
button on the toolbar to the left of the screen.  The object will then be deleted from the layer. 
 
Move to top: If you have an object that is covered by another graphics object on the same layer, you can 
use the “TO TOP” button on the toolbar to uncover the object.  To use this feature, select the object to 
uncover.  Once selected, click the “TO TOP” button.  This will uncover the selected object, forcing it to 
cover the original covering object.  
 
Move to back: While adding graphics, you may cover a smaller graphic completely.  To get access to the 
object, you need to use the “TO BACK” button to push the larger graphic behind the smaller object.  This 
is done much in the same way as “Move to top”, only you select the graphic covering the smaller object 
and clicking the “TO BACK” button on the toolbar.  The smaller object will now be visible. 
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Working with the Text Layer 
 
The text layer allows you to annotate your maze.  When adding text, you have full control over the font, 
style, size, effect and color of the text to add.  Also note that any text added to this layer will overlap all 
other layers.  Working with the text layer is much like that of the graphic layers only you are working with 
text objects rather than graphic objects. 
 

After selecting the text layer, the toolbar on the left will appear. 
 
Adding and object:  Left clicking and dragging will display a rectangle.  Once you have the 
size of the object you wish to add, let go of the left mouse button.  This will open a font select 
dialog box so you can select the size, style, color, etc of the text object you wish to add.  Select 
“OK” when you are satisfied with your selection.  An edit box will now be formed within your 
selected area.  Enter the text as you want it in the box. 
 
Select/Edit an object: The currently selected text object will have an edit control where you 
can change the text if desired.  To change the selected object, float the cursor over the new 
object and left click.  An edit control will now form for you to edit the selected text object. 
 
Unselect an object: If you desire, you can unselect the current object.  This makes moving 
and resizing of a text object easier.  This can be accomplished by left clicking somewhere on the 

layer and releasing where no object exists.  This can also be done by changing to another layer and then 
back again. 
 
Moving an object: First, make sure the object to move is unselected.  Place the cursor over the object, 
left click and drag the object to its new location.  Once in place, release the left mouse button to finish the 
move.  That object will now become the selected text object. 
 
Resize an object: Float the cursor over one of the eight control handles for the object to be resized.  To 
make this easier, make sure the object is unselected.  The cursor will change to an arrow indicating the 
directions it will resize the object.  Left click and drag the control handle to its new location to resize.  
Release the left mouse button when you have achieved the desired new size to complete the action.  The 
text will word-wrap to fill the new object outline.  That object will now become the selected text object. 
 
Delete an object: You can delete the currently select object at any time by clicking the “DELETE” 
button on the toolbar to the left of the screen.  The object will then be deleted from the layer. 
 
Move to top: If you have a text object that is covered by another object, you can use the “TO TOP” 
button on the toolbar to uncover the object.  To use this feature, select the object to uncover.  Once 
selected, click the “TO TOP” button.  This will uncover the selected object, forcing it to cover the original 
covering object.  The current object will become unselected. 
 
Move to back: While adding text, you may cover a smaller text object completely.  To get access to the 
object, you need to use the “TO BACK” button to push the larger object behind the smaller object.  This is 
done much in the same way as “Move to top”, only you select the object covering the smaller object and 
clicking the “TO BACK” button on the toolbar.  The smaller object will now be visible.  The originally 
covering object will become unselected. 
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Getting your work out of Maze Creator 
 
Copy to the clip-board 
 
To rapidly integrate Maze Creator designs into other applications, copy the current design to the clip-board.  
The current design can be at any stage, Template, Maze, or Solution.  To do this selecting the Edit menu 
then Copy.  You can then go to your other application to paste the maze. 
 
Save to BMP  
 
Templates/Mazes/Solutions can now be exported as BMP files.  First, display the template, maze or maze 
with solution to export.  Then from the File menu select Save to BMP.  They will have the number of 
colors as your current display mode and the size of the BMP can be configured as follows: 

 
If you use the “Set to Screen Resolution”, your bitmap dimensions will be ignored and you will get a 
BMP similar to what you see on the screen.  This is the closest to WYSIWYG (what you see is what you 
get).  If you don’t select this option, you can select the dimensions of the exported BMP manually by 
setting X & Y.  After selecting OK, you will be confronted with the file save dialog box to choose a 
location and name for the exported file. 
 
 
Save to EMF 
 
First, display the template, maze or maze with solution to export.  Then from the File menu select Save to 
EMF.  Exports the current displayed image as an EMF file.  A file dialog box will open for you to choose a 
location and name for the exported file. 
 
PRINT PREVIEW 
 
Use FILE -> Print Preview to see what your maze is going to look like.  You will see on Page 1, you 
maze and on Page 2 the solution.  When you are ready, you can PRINT your maze. 
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PRINT 
 
Printing is easier than ever with Maze Creator.  Once you select print, you will see the following dialog 
box: 

 
You can choose to print the Maze, the Maze Solution or both.  Simply place a check mark next to what you 
wish to print.  You can use the “Select Printer” button to choose a printer other than your default.  If you 
are happy with your print settings, click the PRINT button.  This will send your output to the Windows 
printer device of your choice.   Note that you don’t have to select a physical printer.  It could be a FAX, 
PRINT CAPTURE, or other windows compatible print device. 
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List of Features by Product 
 

PRODUCTS: 
Free 
Maze 

Creator 

Maze Creator 
HOME 

Maze Creator 
STD 

Maze Creator 
PRO 

Latest Version Released 1.90 1.90 3.60 1.60 
Distribution Freeware Commercial Shareware Commercial 

Limitations NONE NONE Trial 45 Days NONE 
     

Template Styles 
SQUARE YES YES YES YES 

TILES YES YES YES YES 
TILE INCLUDED 1 5+ 5+ 5+ 

CUSTOM TILERS NA YES YES YES 

HEX NA YES YES YES 

OCT-BOX NA  YES YES YES 

TRIANGLE NA  YES YES YES 

Trapezoid-Box NA  YES YES YES 

Quad-Triangle NA  YES YES YES 

Circular NA  YES YES YES 

Template Functions 
Blacken YES YES YES YES 

Erase YES YES YES YES 
Clear YES YES YES YES 

START/STOP YES YES YES YES 
Reset YES YES YES YES 

Seed Maze YES YES YES YES 
Set Page Size YES YES YES YES 
Set Cell Size YES YES YES YES 

Set complexity YES YES YES YES 
Pen Width YES YES YES YES 

Restore YES YES YES YES 
Maze Creation Features 

Maze Template Layer YES YES YES YES 
Add Text to maze YES YES YES YES 

  Select Font YES YES YES YES 
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  Select Font Style YES YES YES YES 
  Select Point Size YES YES YES YES 
  Select Effect YES YES YES YES 
  Select Color YES YES YES YES 

Import Images into 
maze NA  YES YES YES 

Import GIF, TIF, BMP 
images NA  YES YES YES 

Supports Transparent 
Images NA  YES YES YES 

Background Layer NA  YES YES YES 

Foreground Layer NA  YES YES YES 

Control Maze 
Generation algorithm NA  YES YES YES 

Maze Template Colors: 
Maze, Blackened, 
Erased, Solution, 
Visible/Hidden 

Start&Stop 

NA  NA  NA  YES 

Support Alpha Blends NA  NA  NA  YES 

Control "Relative 
Direction" Maze 

Generation algorithm 
NA  NA  NA  YES 

Draw your own solution NA  NA  NA  YES 

Interactive Features 
Creation Animation YES YES YES YES 

Info Window YES YES YES YES 

Productivity Features 

On-Line Galleries YES YES YES YES 
Import Mask YES YES YES YES 

Generate Maze YES YES YES YES 
Solution Generation YES YES YES YES 

Maze & Solution Output Options 

Print YES YES YES YES 

Print w/ Solution YES YES YES YES 
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Multiple unique mazes 
Print w/ Solutions YES YES YES YES 

Export BMP Maze & 
Solution NA  NA  YES YES 

Export GIF Maze & 
Solution NA  NA  YES YES 

Export TIF Maze & 
Solution NA  NA  YES YES 

Export EMF NA  NA  YES YES 

Export Clip-Board  NA  NA  YES YES 

Multiple BMP,GIF,TIP 
Export w/ Solutions NA  NA  NA  YES 

Commercial Publishing 
No Maze Creator 

Reference required 
NA  NA  NA  YES 
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TECHNICAL SUPPORT 
 
Updates can be found at WWW.MAZECREATOR.COM 
 
Registered Users can obtain technical support by one of two methods.  You can send an e-mail message 
including you registered Email Address number to: 
 
support@mazecreator.com 
 
 
 

Credits 
 
Maze Creator utilizes some freeware software libraries: 

• CxImage: A Open Source graphic library initiated by Davide Pizzolato.  More 
information can be found at www.cximage.com. 

• Tommy Cole for his music which he has supplied Maze Creator and is include in 
the Flash Tutorial. 
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PRO REVISION HISTORY 
  

New in 1.60: 
• ADDED: Wrap maze Horizontally and Vertically  
• ADDED: Mouse Gestures, command Maze Creator by mouse movements  
• ADDED: Paste graphics into Foreground & Background from Clipboard (DIB, BITMAP, 

ENHMETAFILE)  
• ADDED: Paste text into Text layer  
• IMPROVED: Maze generation algorithm, closer adherence to generation rules should make more 

complex mazes  
• IMPROVED: User Interface to help make selections more obvious  
• ADDED: COLOR selection to over-ride the default Maze Creator Color scheme 

o Maze Pen Color  
o Solution  
o Blacken  
o Erased (Only during Design of Template)  
o Start/Stop colors both visible and hidden for design purposes 

• ADDED: Opacity setting for TILER, now supports version TLE 1.50  
• ADDED: prototype of 3D Maze Rendering (you will not see this feature)  
• ADDED: start of Image Processing dialog (you will not see this feature)  

New in 1.50: 
• ADDED: TILER Gallery added, download and install new TILERs as they are released 
• ADDED: Save MZE Files version 2 file format, includes all text & images 
• FIXED: Some printer drivers failed to accept a High Resolution Maze, Maze Creator will now 

slowly reduce the resolution of the image until the printer driver accepts the graphics.  This will 
slow down printing for some, but increase driver compatibility.  A few specific drivers, such as 
Adobe Acrobat, need this for proper support. 

• FIXED: Random number generator sometimes seeded the same maze on fast computers 
• ADDED: Multiple mazes with Solutions during print 
• ADDED: Multiple "Image File" Export with Solutions 
• ADDED: Export of "Image File" with Solution 
• ADDED: ReRender Maze Option to generate a new maze with solution from the same template 
• FIXED: Preview when selected a Tiler option 
• FIXED: Reading *.tle files, properly handles last entry if last line is not a blank line 
• FIXED: Export to Image File right and bottom edge got clipped with a fine pen size 

New in 1.40: 
• FIXED: With printing high density mazes, the bottom of the maze may have been cut-off 
• FIXED: Better printer compatibility 
• FIXED: Maze Creator will detect and warn if it cannot contact the license server 
• ADDED: Debug option to collect information while printing for customer support 

New in 1.30: 
• DRAW YOUR OWN SOLUTION BETA (Please give feedback and ask questions) 
• Fixed "File -> New" issue, now a new maze will clear current template space 
• Direct links to help pages from HELP menu 
• Fixed bad default value that caused page size issues 
• Major bug fixes with Load/New file handling, this may have lead to certain Windows 

Compatibility issues 
• START/STOP Left button = Hidden, Right button = Color Shown 
• Automatic START/STOP (if you don't set one), default to hidden style 
• Fixed Tiler, BLACKEN/ERASE didn't map properly 
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• Added START/STOP to Tiler features 
• "Drive C could not be found, you may not register this software" error eliminated (Very rare, in 

cases you don't have a "C" drive) 
• Real-time update of screen when Tiler is selected 
• Optimized printed doesn't work for all users, disabled 
• Printing, printing; Many improvements, upper left corner is moved into printable range for your 

printer 
• Updates Screen will now shrink if you start a maze project 

New in 1.20: 
• Tiler maze template type 
• Import TIF, GIF, and BMP Images 
• Export TIF, GIF, BMP, and EMF files 
• Alpha Blend Images into Template 
• Transparent GIF file supported 
• Minor speed improvements 
• Minor Bug fixes 

New/Fixes in 1.10 
• Layer buttons better labeled 
• Application Startup speed improved 
• Some overall speed improvements in growing the maze 
• BMP export has been fixed to remove extra whitespace 
• EMF export has been fixed to remove most of the extra whitespace 

Fixes  in 1.02: 
• Fixes some Windows XP bugs 
• TEXT tool crashes Maze Creator PRO 
• With no background image, the Maze Creator paper is used and printed by default 

New in 1.01: 
• First public release 
• TEXT style can be changed, color, font, etc 

o Select Font 

o Select Font Style 

o Select Point Size 

o Select Effect 

o Select Color 

New in 1.00: 
• Some interactive rendering issues resolved (output was fine, but UI had problems) 
• Add images to the maze background or foreground 
• Add text to the maze 
• Send to printer with solution 
• Solution generated as soon as a maze is created 
• Complete control over maze creation algorithm, hard direction and relative direction parameters 

can be set 
• User interface more straight forward, more menu items in the proper dropdown 
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APPENDIX A – HOT KEY SHORTCUT REFERENCE 
 

HOT KEY SHORTCUTS 
 

FUNCTION HOT KEY  FUNCTION HOT KEY 
File New CTRL+N  Maze Tool – SETUP ALT+[ESC] 
File Open CTRL+O  Maze Tool - RESET ALT+R 

File Save Template CTRL+S  Maze Tool - BLACK ALT+B 
Save Image CTRL+I  Maze Tool - ERASE ALT+E 
Save EMF CTRL+E  Maze Tool – START ALT+< 
File Print CTRL+P  Maze Tool – STOP ALT+> 
Edit Copy CTRL+C  Maze Tool - MySolution ALT+Z 

Template Gallery CTRL+[F1]  Maze Tool - SEED ALT+S 
Tiler Gallery CTRL+[F2]  Maze Tool – MAKE ALT+[SPACE] 
Mask Gallery CTRL+[F3]  Apply Template Mask ALT+M 

ReRender Maze CTRL+R  OBJECT TOOLS 
Clear Maze CTRL+ALT+C  Object Tool - Delete ALT+X 

   Object Tool – Move Top ALT+[UP] 
   Object Tool – Move Bottom ALT+[DOWN] 

 
 

LAYER SHORTCUTS SET ACTIVE TOGGLE VISIBLE 
Back Ground CTRL+1 CTRL+SHIFT+1 
Maze Layer CTRL+2 CTRL+SHIFT+2 

Fore Ground CTRL+3 CTRL+SHIFT+3 
Text CTRL+4 CTRL+SHIFT+4 

Solution  CTRL+SHIFT+5 
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APPENDIX B - Mouse Gesture Quick Reference 
 

Initiate Mouse Gestures by holding the “CTRL” button and making the gesture with your left 
mouse button depressed.  Alternatively, tap the “SPACE” bar and the next left mouse button 

mouse movement will be interpreted as a gesture. 
 

The gesture is sensitive to direction of the mouse trace.  To accurately trace a gesture, refer to the 
table below, trace from the RED to the BLUE. 

 
Valid Gestures on all Design Layers 

 
“CIRCLE” 

Opens the SETUP screen 
 

“C” 
Copies the current maze image to 

the clipboard 
 

“Z” 
Opens the file save dialog box 

 
“S” 

Toggles the Show Solution view 
option 

 
“Left-Right” 

Rolls through different design 
layers to left 

 
“Right-Left” 

Rolls through different design 
layers to right 

 
“Question” 

Opens this Quick Reference 
Guide 

   

Valid Gestures only on Graphic & Text Design Layer 

 
“M” 

Jumps to Maze Template design 
layer 

 
“P” 

Paste clipboard object into 
current design layer 

 
“Rectangle” 

Delete current object from design 
layer 

 
“Up-Arrow” 

Move current object to top of 
current design layer 

 
“Down-Arrow” 

Move current object to top of 
current design layer 
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Mouse Gesture Quick Reference 
 

Initiate Mouse Gestures by holding the “CTRL” button and making the gesture with your left 
mouse button depressed.  Alternatively, tap the “SPACE” bar and the next left mouse button 

mouse movement will be interpreted as a gesture. 
 

The gesture is sensitive to direction of the mouse trace.  To accurately trace a gesture, refer to the 
table below, trace from the RED to the BLUE. 

 
 

Valid Gestures only on Maze Template Design Layer 

 
“P” 

Open PRINT dialog box 

 
“M” 

Apply image mask to current 
maze template 

 
“R” 

Re-render Maze & Solution 

 
“Left-Arrow” 

Select START Tool 

 
“Right-Arrow” 

Select STOP Tool 

 
“Backslash” 

Select RESET Tool 

 
“Reverse-Slash” 

Select BLACK Tool 

 
“Slash” 

Select ERASE Tool 

 
“Reverse-Backslash” 

Select SEED Tool 

 

     
     
     
     
     
     

 


